Required Browsers needed for Accessing the HelpDesk

 

The software used to provide our HelpDesk services, Zendesk, no longer supports older browsers that are not TLS v1.2 compliant as of June 14, 2018.  This change was implemented in order to provide you the most secure online support experience and maintain compliance with the PCI Data Security Standard (PCI DSS) for safeguarding customer's personal data.

Therefore, starting June 14, 2018, the minimum browser versions for logging in and accessing the HelpDesk include browsers such as Internet Explorer 11, Mozilla Firefox 27, Google Chrome 30 or Apple Safari 7. iOS 5.1 and Android 5 Lollipop or later will be required.

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk